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 1. Introduction  

1. Introduction
Radar is a real-time interactive graphical application for remotely monitoring one or more Radiator Radius
servers. Radar allows administrators to remotely monitor, analyze and change the behaviour of Radiator.

Radiator is a highly portable and configurable Radius server from Radiator Software Oy. (see https://
radiatorsoftware.com/radiator [https://radiatorsoftware.com/radiator]). Radar is a separate product (see https://
radiatorsoftware.com/radar [https://radiatorsoftware.com/radar]) which may come bundled with your Radiator
purchase.

Radar makes an authenticated TCP connection to one or more Radiators. It periodically checks the health
of each connected server and provides tools for monitoring, analyzing and changing the behaviour of each
Radiator.

Using Radar, administrators can:

• Receive notification of Radiator problems by email, external programs or GUI popup windows.

• View error and message logs.

• Enable message logging direct to a Radar window. Temporarily turn on debugging only when it is
required.

• Plot over 20 statistical measures such as Total requests, Average response time etc.

• Plot statistics for the server as a whole, or for individual Client, Realm, Handler, AuthBy or Host clauses.

• Remotely restart Radiators.

• View and Change the value of selected Radiator configuration parameters.

The rest of this document describes how to install, configure and operate Radar. The intended audience is
experienced network administrators who are responsible for maintaining a Radiator installation.

2. Quick Start and Evaluation guide
For the keen and experienced administrator, this section contains very brief instructions for getting started with
Radar. More detailed instructions for installing, configuring and using Radar are found in later sections.

1. Confirm you have perl (version 5.6.0 or later) and Tk (version 800.023 or later) installed.

2. Download, install and configure Radiator 3.0 or later.

3. Add a <Monitor> clause to your Radiator configuration file. See goodies/monitor.cfg in your Radiator
distribution for instructions and examples, or see Radiator Configuration on page 5, of this manual for
a simple example <Monitor> clause. The <Monitor> clause allows Radar to connect to Radiator.

4. Start your Radiator.

5. Unpack your Radar distribution. Use gunzip and tar on Unix. Use WinZip on Windows.

6. Change directory to the unpacked Radar distribution.

7. Run the command:

• perl radar

• You should see the Radar main window appear.

8. Choose File->Monitor a new Radiator server. Enter Radiator server host and port details, then username
and password. Make sure username and password match the configuration in the Monitor clause above.
The server should appear in the server list on the left hand side of the window in green.
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9. Click on the server name. Choose Tools->Trace Log. You should see a message log window appear in the
tools area on the right. Change the log level with the option menu.

10. Click on the server name. Choose Tools->Plot Statistics. You should see a plotter window appear in the
tools area on the right. Click Properties... to plot other statistics from the server, or to change the plotter
behaviour.

11. Choose File->Change Radar Configuration... to view and change Radar and announcements behaviour.

12. Choose File->Save Radar Configuration, so the next time you start Radar, you will monitor the same
servers with the same tools.

3. Deployment Architecture
Radar is an interactive graphical application which can display on Microsoft Windows or on any X windows
display.

Since Radar is a well behaved X windows application (on Unix), and because it connects to Radiator by TCP,
there is a great deal of flexibility with where you can deploy Radar in relation to your Radiators and your
display workstations.

3.1. Single Host

In the simplest architecture, you might have a single computer (with its own display) running both Radiator and
Radar. The host could be any Unix or Windows computer. In this case, you would configure Radar to monitor
the single Radiator at localhost:9048, and Radar would display on the host computer's display.

Figure 1. Example single host deployment architecture

3.2. Multi Host

In a larger and more complicated installation, you might have multiple independent Radiators running on
several different hosts throughout your network. You could then run Radar on your personal workstation. Radar
would connect by TCP to each Radiator and display itself on your workstation, allowing you to monitor all the
Radiators from one location.
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Figure 2. Example multi host deployment architecture

3.3. Remote display

You might want to use Radar from a remote or home workstation, but security and firewalling issues may mean
that you can't make a Radar connection on TCP port 9048 from home to your Radiators. In that case, you could
run Radar on an internal host, and use an SSH forwarded X windows connection to display Radar's window on
your home computer.

Figure 3. Example remote display deployment architecture

4. Installation
Radar is a well-behaved perl application, and is packaged as a conventional perl distribution, which may be
installed on Unix or Windows An RPM package suitable for most Linux versions is also available.

4.1. Requirements

• Any Unix or Windows computer with a graphical display (X windows on Unix)

• Radiator 3.0 or later

• Perl 5.6.0 or later

• Perl TK 800.023 or later

• Net::SMTP (if using email announcements)

• Approximately 4 MB of disk space

4.2. Unix

1. Ensure that Perl 5.6.0 or later is installed

 Reference Manual for Radar, a real-time monitor for
Radiator Radius servers. For Radar Revision 1.7

3 of 21



 4. Installation  

2. Ensure that Perl TK 800.023 or later is installed

3. Unpack the distribution in a work area with

zcat Radar-1.0.tgz|tar xvf -

4. cd Radar-1.0

5. perl Makefile.PL

6. make

7. make test

8. Log in as, or su to root:

make install

9. Any user can now run Radar by typing:

radar

4.3. RPMs

The Radar RPM package is suitable for use with RedHat 7, SuSE and other Linux distributions.

1. Log in as root

2. Ensure that Perl 5.6.0 or later is installed

3. Ensure that Perl TK 800.023 or later is installed

4. rpm -Uvh Radar-1.0-1.noarch.rpm

5. Any user can now run Radar by typing:

radar

4.4. Windows

The Radar Makefile.PL includes support for Windows systems without nmake.

1. Download and install ActivePerl from http://www.ActiveState.com/ActivePerl [http://
www.ActiveState.com/ActivePerl]. During installation, accept all the defaults. Allow setup to reboot your
computer if it needs to.

2. Connect your computer to the Internet so you can download any required Perl modules from ActiveState
using PPM.

3. Double click on c:\perl\bin\ppm (the Perl package manager). You will get a command line screen running
ppm with a PPM> prompt.

4. Type the command:

• install Tk

• The perl Tk module wil be installed for you.

5. Close the PPM window. Perl and Perl Tk is now installed.

6. Unpack your Radar distribution to a suitable location. Recent versions of WinZip can be used to
decompress and unpack the distribution file.
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7. Start an MSDOS command window, change directories to the place where you unpacked Radar.

8. Type

perl Makefile.PL

This will check that your distribution is complete.

9. Run the regression tests with

perl test.pl

You should see some lines like "ok xx", and none saying "not ok xx".

10. Install Radar by typing:

perl Makefile.PL install

11. You can now run Radar by typing:

radar

5. Radiator configuration
Before Radiator will accept connections from Radar, it must be properly configured to include a <Monitor>
clause. If there is no <Monitor> clause in the Radiator configuration file, Radar will not be able to connect to
and monitor that Radiator.

For more extensive details on options for the <Monitor> clause, see the Radiator reference manual. However,
below is a minimal <Monitor> clause that will permit some initial testing. It will permit Radar to connect from
anywhere to the default TCP port of 9048, using the username `mikem' and password `fred'.

<Monitor>

        Username mikem

        Password fred

</Monitor>

Tip
You can control the username, password, authentication method and much more with parameters in the

<Monitor> clause. See the Radiator reference manual for more details.

Tip
If you change your Radiator configuration, you will need to restart Radiator before the new

configuration comes into effect.

6. Operation
This section describes how to start, run, configure and use Radar.

6.1. Command line arguments

Radar understands a number of command line arguments:
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radar [-h] [-v] [-d] [-i inifile] [tk options]

• -h Print usage text and exit.

• -v Print Radar version number and exit.

• -d Debug, print out details of commands sent to and from each Radiator, plus other Radar debugging detail.
Useful only for Radar maintainers and customisers.

• -i inifile Specifies an alternative configuration file location. The default location is .radar.ini in the users
home directory on Unix, and radar.ini in the current directory on Windows.

• tk options Radar understands all the generic Tk options such as -background, -class, -display, -font, -
foreground, -geometry, -iconic, -motif.

Examples:

Run radar on Unix with the default config file:

radar

Run radar on Microsoft Windows with a common configuration file location:

radar -i c:\radar.ini

Run radar on Unix, starting with a custom config file, the window at 800 pixels wide and 400 pixels high in the
top left corner of the display on 10.1.1.2:

radar -i /share/radar.ini -geometry 800x400+0+0 -display 10.1.1.2:0.0

6.2. Configuration

You can change and adjust many Radar configuration parameters with:

• File->Edit Radar Configuration

• Select a server, use Tools->Properties

• On a logger, change the logging level menu

• On a plotter, use the Properties... button

When Radar starts up, it attempts to restore its previous configuration from a configuration file. The default
location of the Radar configuration file is:

• .radar.ini in your home directory on Unix

• radar.ini in the current directory on Windows

The location of the configuration file can be changed with the -i flag (see Command line arguments on page
5).

Radar can save its configuration to the configuration file, so that each time you start Radar, it will start up with
the same configuration as before, monitoring the same servers, and with the same loggers and plotters visible.

By default, Radar only saves its configuration when you select File->Save Radar Configuration. However, if
you enable `Auto Save Configuration' in File->Edit Radar Configuration..., under the General tab, then Radar
will save the new configuration every time the configuration is changed.
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CAUTION

The configuration file may contain Radiator access passwords. If so, ensure the configuration file is

suitably protected against access by unauthorized personnel.

Tip

In order for Radar to start next time with the same configuration, save the current configuration with

File->Save Radar Configuration, or set Auto Save Configuration in File->Edit Radar Configuration,

General tab.

The following chapters describe configuration options that are available under the File->Edit Radar
Configuration menu.

6.2.1. General

• Skip Splash Screen: Causes Radar not to display its splash screen when it starts up. By default, the splash
screen is displayed.

• Auto Save Configuration: If this is set, Radar will automatically save its configuration whenever you
change the configuration. If it is not set, the configuration will only be saved of you choose File->Save
Configuration File. By default it is not set.

6.2.2. Announcements

Radar can alert you with an `announcement' whenever certain events (both good and bad) occur. You can tell it
how to alert you with a different method for each type of event.

Radar can announce the following events:

• connected: Radar has successfully connected or reconnected to a Radiator. This is a normal and correct
event.

• disconnected: Radar has become disconnected from a Radiator. This usually means that the Radiator has
exited, or there is some network or TCP connectivity problem between Radar and Radiator. Radar will
periodically attempt to reconnect. (The time between reconnection attempts is given by the `Ping interval'
parameter in the host's Tool->Properties dialog).

• loggedin: Radar has successfully connected to and logged in to a Radiator. This is a normal and correct
event.

• stalled: A Radiator is still connected by TCP to Radar, but it has stopped responding to Radar commands
for more than a certain period of time. (The period is set by the `Stalled Time' parameter in the host's Tool-
>Properties dialog). This generally indicates a problem with the Radiator, since it will probably not be
responding to Radius requests either.

• clock_skewed: A Radiator's local clock disagrees with the Radar host's clock by more than a certain
amount. (The amount is set by the `Max clock skew' parameter in the host's Tool->Properties dialog). This
can be a problem, because it might mean that accounting data is recorded inaccurately.

• connect_failed: Radar has attempted to reconnect to a Radiator but failed. Repeated failures due to the
same reason will only be announced once. This is usually due to the target Radiator not running, or a
network or TCP connectivity problem.
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For each type of event, you can tell Radar what method(s) to use to alert you. You can choose one or more of
the following:

• Beep: Beeps or rings the bell on the display.

• Popup Window: Pops up a non-modal window with text describing the event. Click on OK to make the
window disappear.

• Email: Send email to a designated address. You can configure the To: address, From: address and the
SMTP server to use. If To: is not set, sends email to `radar'. If From: is not set, marks the mail as from the
current user. If SMTP Server: is not set, uses the mail server on the local host. The Subject is set to `Radar
event announcement'. Hint : requires the Perl Net::SMTP module to be installed.

• Run program: Runs an external program. Specify the full path to the program and any command line
arguments. The program runs as the same user that is running Radar. In the command line, a number of
positional parameters can be replaced automatically: %0 is replaced by the current time. %1 is replaced
by the name of the event type (`connected', `disconnected' etc). %2 is replaced by the name of the host
reporting the event. %3 is replaced by the text of the announcement message.

Tip

With most shells, you would have to put quotes around %0 and %2, since they may contain spaces.

6.3. Monitoring a new Radiator

When Radar starts for the first time, you will be presented with an empty screen similar to Figure 4. Radar just
after it is started for the first time on page 8 . No Radiators are being monitored, and no monitoring tools
are visible.

Figure 4. Radar just after it is started for the first time

In order to monitor a Radiator, you must first configure it into Radar. Before you can monitor a new Radiator,
you will need to know the DNS name or IP address where it is running, and its Monitor port number. You will
also need to know a valid username and password that can be used with the Radiator Monitor. If you don't know
this information, consult your Radiator server administrator. To configure Radar to monitor a new Radiator,
choose Tools->Monitor new Radiator server.... You will then see a dialog similar to Figure 5. Enter host name
or address and port number on page 9.
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Figure 5. Enter host name or address and port number

Enter the DNS name or IP address of the Radiator host. The default of `localhost' means `on the same computer
where Radar is running'. Also enter the port number that the Radiator Monitor is listening on. The default port
of 9048 is the same as the default port that the Monitor clause uses. See Radiator configuration on page 5
for more details. Press Return, or click on OK. You will then see a login dialog similar to xFigure 6. Enter
Username and Password on page 9.

Figure 6. Enter Username and Password

Enter a valid Username and Password to authenticate the Radar connection to the Radiator Monitor. If the
Username and Password are accepted by the Radiator, you will see the entry in the server list window change to
loggedin, similar to Figure 7. Radar connected and logged in to Radiator on page 9. If the Username and
Password are not accepted, you will be prompted for them again.

Figure 7. Radar connected and logged in to Radiator
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Tip

In order to automatically reconnect to the same servers next time you start Radar, save the current

configuration with File->Save Radar Configuration.

Tip

There is a right mouse button menu available on the server list window, containing the same options as

in the Tools menu.

6.3.1. Server states

After connecting to a Radiator, Radar continually monitors the health of the connected Radiator. It displays
information about the health of each connected Radiator in the server list window. Radar can detect and display
a number of different states of health:

• disconnected:
Red
The TCP connection to the Radiator has been broken or lost. Perhaps the Radiator has stopped running, or
perhaps there is a network or TCP connectivity problem between Radar and the Radiator.

• connected:
Purple
A TCP connection has been established. Radar is waiting for a CHAP challenge before it can start to log
in. This is a normal stage while connecting or reconnecting to Radiator. It should only last for a second at
most.

• loggingin:
Blue
Radar is in the process of logging in to Radiator: it has connected by TCP and received a CHAP challenge.
It has sent a LOGIN command and is waiting for the result.This is a normal stage while connecting or
reconnecting to Radiator. It should only last for a second at most.

• loggedin:
Green
Radar has successfully logged in. All the tools for that Radiator are now operational.

• stalled:
Yellow
Radar is still connected by TCP but it has not received a response from Radiator for more than a certain
interval of time. This generally indicates a problem with the Radiator, since it will probably not be
responding to Radius requests either

6.3.2. Changing server details

After adding a new server, you may want to change some of the configurable parameters for that server. The
default values that Radar uses for new connections are perfectly suitable for most uses, but for advanced or
unusual situations, you may wish to customize them.

To change server details, click on the servers entry in the server list, then choose Tools->Properties. A dialog
similar to Figure 8. Changing host monitoring details on page 11 will appear.
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Figure 8. Changing host monitoring details

You can change any or all of the server configuration parameters:

• Title: This is the name that will be used for the server in the server list. It defaults to the hostname and port
number, but you might want to change it to something that is more meaningful for your organization, such
as `Primary Radius' or `Secondary Radius'.

• User Name: The username that will be used to authenticate connections to this server.

• Password: The password that will be used to authenticate connections to this server.

• Ping interval: The time interval (in seconds) between attempts to contact the server. If the server is not
currently connected, Radar will attempt to reconnect after each interval. If the server is connected and
logged in, Radar will send an ID request each interval, so it can confirm that the Radiator is running
properly and is not stalled.

• Stalled time: The time interval (in seconds) to determine that a Radiator is stalled. If no response
is received from the server for more than this time, it will be marked as `stalled' and the `stalled'
announcements (if any) will be made.

• Max clock skew: The maximum permissible time difference (in seconds) between the Radar host clock
and the Radiator host clock. If this difference is exceeded, the `clock_skew' announcements (if any) will be
made.

Tip

In order to reconnect with the same parameters next time you start Radar, save the current configuration

with File->Save Radar Configuration.

Tip

Use a time synchronisation system like NTP to synchronise the clocks on your Radar and Radiator hosts.
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6.4. Viewing the Trace message log

You can optionally display a Trace message logger for each monitored Radiator. This allows you to easily see
error and warning messages sent by Radiator, and optionally to enable debug messages, allowing you to analyze
how and why Radiator is handling certain requests.

Radar Trace logging is in addition to and completely independent of any other logging configured into Radiator.
If you have your Radiator configured to log ERR messages to a FILE, it will continue to do so irrespective of
the settings of the Radar Trace logger.

To view a Trace logger for a Radiator, click on the server in the server list, then choose Tools->Trace log. You
will see a logger window in the tools area, similar to Figure 9. Viewing a Radiator Trace message log on page
12.

Radar can only show one logger per server. If you try to view a new one, nothing will happen.

As Trace log messages arrive, they are scrolled upwards in the logger window, so the most recent messages
are always visible. The standard Tk text menu is available with the right mouse button, allowing you to cut and
search for text. All the messages received by the logger are kept in the text buffer (and therefore within Radar)
until the logger window is closed.

CAUTION

This can mean that Radar memory usage can grow very large if you turn it on to debug logging on a

busy server.

Figure 9. Viewing a Radiator Trace message log

The logger window can be resized vertically at any time by dragging the adjuster in the lower left corner of the
window.

You can change the Trace level for the Radar logger at any time with the level option menu in the logger
window. Radiator then only sends log messages that are at or above the trace level set by the trace level menu in
Radar.

You can specify a logger Filter, so that the logger will only show messages resulting from Radius requests
that satisfy the filter and which are at or above the current Trace level. To create or alter a filter, click on the
Filter... button. A dialog will appear,allowing you to specify one or more Radius attributes, values and matching
rules. Only Radius packets that satisfy all the rules will be logged to the Radar logging window. To accept the
new filter, click on OK. The filter rules wil be printed in the logger window, and the new filter will take effect
immediately.
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Figure 10. Editing the logger packet filter

6.5. Viewing statistics

You can optionally display and plot statistics gathered by each monitored Radiator. Radiator gathers over 20
statistical measures for the server as a whole, and for each Radiator object (i.e. for each Client, Realm, Handler,
AuthBy and Host in the Radiator configuration). Radar allows you plot any or all of the available statistics from
any or all objects within a Radiator.

Plotting statistics allows you to see, for example, when Total throughput is unusually low, or if Average
response time is usually high, indicating a problem in the authentication system. Many other interesting and
useful statistics are also available, allowing you to keep close tabs on the health of your authentication system.

To view a plotter for a Radiator, click on the server in the server list, then choose Tools->Plot statistics. You
will see a plotter window in the tools area, similar to Figure 11. Viewing a Radiator statistics plot on page
13. This plotter will show statistics gathered for the server as a whole.

To view a plotter for an object with Radiator, expand the server in the server list by clicking on the +. The server
will expand to show all the configurable parameters and objects at that level within the server. You can drill
down to see objects embedded within other objects. For example, to plot statistics for a single Client, click on
+ next to the server name to expand it, then click on the + next to Client. It will expand to list the name of each
Client in the Radiator configuration. Click on the Client name, then choose Tools->Plot statistics. You will see a
new plotter window in the tools area, similar to Figure 10 on page 15. This plotter will show statistics gathered
for just that Client

Figure 11. Viewing a Radiator statistics plot

You can have any number of plotters for any number of Radiator internal objects. For example, you could
have a `Total requests' plotter for the server as a whole, a separate `Average Response Time' plotter for the
server as a whole, a `Bad authenticators in accounting requests' for a certain Client that is currently causing
trouble, and a `Total requests' plotter for a Host in an AuthBy RADIUS, showing how many requests are being
proxied. Furthermore, each plotter can plot any number of the available statistics for that object at the same
time. However, it is not possible to have statistics from two different objects plotted in the same plotter. See
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Figure 12. Viewing multiple statistics plots on page 14, showing an example of Radar plotting statistics for
two different servers.

Note that if a Radar becomes disconnected or unavailable while being plotted, the plot line for that Radiator
will not be drawn while it is disconnected. This means there may be gaps in the plot line reflecting times when
there was no statistical data available from that server. This is normal behaviour for Radar, but the cause of the
diconnection should be investigated.

Figure 12. Viewing multiple statistics plots

For each plotter, you can extensively customize what statistics are displayed and how they are displayed. You
can add and remove data items from the plotter, change colors and titles, and change the scale factors and
plotting frequency.

To change the configuration of a plotter, click on the Properties button in the plotter. A configuration dialog
similar to Figure 14. Changing plotter configuration Data Sets on page 15 will appear.

The plotter configuration dialog contains two tabs. General (Figure 13. Changing plotter configuration General
on page 15) allows you to configure parameters for the whole plotter. Data Sets (Figure 14. Changing
plotter configuration Data Sets on page 15) allows you to configure each individually plotted statistic.
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Figure 13. Changing plotter configuration General

The general tab allows you to configure the behaviour of the plotter as a whole.

• Title: This field specifies the title to be used to label the plotter window. It appears in the bottom left corner
of the plotter window, to the left of the Properties button. It defaults to the ID of the server and the name of
the object it is plotting.

• Plot every: Specifies how frequently statistical data is to be retrieved from Radiator for this plot. Options
range from 1 Second to 1 Day

• Y Scale: Specifies the range of the Y (vertical) scale. Options include `auto', `0-1', 0-10', `0-100' etc.
Auto means vertical scale will be automatically chosen according to the maximum historical value of the
displayed data, so that the data fits within the vertical scale.

Figure 14. Changing plotter configuration Data Sets
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The Data Sets tab allows you to configure the look of each individual statistic displayed. On the left side, there
is a list of available statistics from that object. Clicking on one will show how it is configured on the right. The
following options are available

• Show: Set this to make the statistic visible in the plotter. If not set, the statistic will not be plotted.

• Show name as: Specifies an alternative name to use for this statistic in the plotter. Defaults to the standard
Radiator name for the statistic.

• Style: Specifies the way to display data points for this statistic. `Lines' means join samples with lines.
`Dots' means plot each data point with a single 1 pixel dot. `Solid' mean plot the data as a filled solid
vertical bar.

• Color: Specifies the color to use to plot this data item.

• Normalise: Specifies how to normalise the data for each statistic. Radiator provides the raw measurement
of each data item. The most common choice is `per sec' which shows the average rate per second. Other
choices include rescaling up or down by factors of 10, allowing differently scaled statistics to be usefully
plotted on the same scale.

The plotter window can be resized vertically at any time by dragging the adjuster in the lower left corner of the
window.

Tip

There is a right mouse button menu available on the plotting area of the plotter window. It includes a

Properties button. If you click the right mouse button close enough to a data sample, it will show the

name of the data item, and the time of the sample.

6.6. Viewing Radiator parameters

Radar allows you to drill down into the monitored Radiators to view and possibly change the Radiator
configuration parameters. Click on the + next to a server in the server list window causes the list to expand and
show all the top level server configuration parameters and clauses, similar to Figure 15. Radiator with expanded
parameter details on page 16. Clicking on the + next to an object or object list causes it to expand in turn.
Using this technique, you can explore the entire Radiator configuration.

Figure 15. Radiator with expanded parameter details
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Many parameters display their current value next to them. You can resize and scroll the server list window to
see more of the parameter list. Some parameters are not able to usefully display all their data values. They will
show up as ARRAY or HASH or similar.

6.7. Changing Radiator parameters

Radar allows you to change selected Radiator configuration parameters. The changes are not permanent: they
only last until the next time the Radiator is restarted (i.e the changes only effect the Radiator internal state).
This feature allows you to quickly experiment with changes to the configuration without constantly restarting
the server. For example, you can change the text of hooks, and set various flags, strings and integers in the
configuration.

To change a configuration parameter, expand the server details in the server list window until you find the
parameter you which to change.

Click on the parameter you are interested in, then choose Tools->Change Parameter Value... You will see
an editing dialog similar to one of the ones shown in Figure 16. Changing a flag parameter on page 17,
Figure 17. Changing a hook parameter on page 18, Figure 18. Changing a string parameter on page 18
or Figure 19. Changing an integer parameter on page 19

Figure 16. Changing a flag parameter
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Figure 17. Changing a hook parameter

Figure 18. Changing a string parameter
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Figure 19. Changing an integer parameter

Edit or change the parameter, then press Ok. The dialog will disappear, and the new value for the parameter will
appear next to the parameter in the server list window.

Using Radar you can only change some of the Radiator configuration parameters. You can change any string,
integer, flag or hook parameter.

Tip

Not all parameter changes have an effect. For example, you can use Radar to change the Radiator

AuthPort, but this will not actually change the port Radiator is listening on.

Tip

One of the more useful flag parameters for testing and debugging is the PacketTrace flag, available

in each object. If a request passes 'through' an object or clause with the PacketTrace flag set, Radiator

will log at DEBUG level all the messages for that request, regardless of the current Trace level. This is

useful, for example, for getting detailed traces for requests coming only from a certain Client.

Tip

When changing a hook, details of any compile errors for the new hook can be seen by opening a logger

window to that server at Error level.

6.8. Restarting a Radiator

You can manually restart any Radiator connected to Radar. To restart a Radiator, click on its name in the server
list window, then choose Tools->Restart Server. This has the same effect as sending a HUP signal: Radiator
restarts by completely rereading its configuration file.
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7. Security
Radar connections to Radiator are authenticated with CHAP. Plaintext passwords are never sent on the
connection. However, Radar connections are not encrypted. If you are concerned about proprietary information
being exposed by sniffing the TCP connection, you should consider tunnelling the Radar TCP connection using
SSH or similar.

If you are using hardwired username and passwords in your Radiator Monitor configuration, you should
take care that unauthorized personnel cannot access the Radiator configuration file to read the Radar access
password.

The Radar configuration file may record the Radar access password for each Radiator saved in the configuration
file. You should take care that it is not readable by unauthorized personnel. The Radar configuration file is in
.radar.ini in your home directory on Unix, and in radar.ini in the current directory on Windows.

8. Getting Help
The following chapter describe various options for getting help.

8.1. Support contract holders

Radar support may be purchased at the time you purchase Radar. See https://radiatorsoftware.com/buy-from-
radiator/ [https://radiatorsoftware.com/buy-from-radiator/] for details. Support contracts last for a limited period
(typically one year) and may include a limited amount of pre-paid email support.

Radiator Software will respond promptly to support email during business hours, EEST timezone. Telephone
support is not provided. We will keep track of the effort required to answer your support email, and inform you
when your prepaid support time has expired.

If you have a Radar or Radius support contract, you may send email to: support@radiatorsoftware.com

Include your support contract identifier in the Subject line. If you don't have a support contract, we will not
respond to your query on this address.

If you need an urgent response outside of the standard email support hours, you may want to post to the Radar
mailing list instead. Someone will be sure to be awake somewhere in the world.

8.2. No support contract

The standard Radar license does not include support, but it does include the full source code and free access to
the Radiator mailing lists. This means you can help yourself, and you can work with other Radar users in the
user community. In order to participate with others in this effort, you can check the available mailing lists and
instructions how to join them from Radiator Mailing Lists [https://radiatorsoftware.com/support/mailing-lists/].

The staff of Radiator Software monitors the mailing lists and frequently answer questions.

Please, don't post HTML to the mailing lists. Not everyone is using HTML compatible mailers.

8.3. What to do if you need help

Before you post to the support address or mailing list asking for assistance, we suggest you go through the
following check list:

1. Consult this reference manual.

2. Consult the FAQ at Radiator Software Frequently Asked Questions  [https://faq.radiatorsoftware.com/] for
extra hints and up-to-date information.
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3. Check the available mailing lists and instructions how to join them from Radiator Mailing Lists [https://
radiatorsoftware.com/support/mailing-lists/]

4. Check that you are using the latest version of Radar. See Radar Downloads [https://
downloads.radiatorsoftware.com/packages/radar/downloads/], use the username and password we have
issued to you. Upgrade if you need to.

5. Check whether there are any patches that address your problem. See if the testing pages link exist for your
release at Radar Downloads [https://downloads.radiatorsoftware.com/packages/radar/downloads/] and
check the packages available. Apply the patch if you think you might need it.

6. If you still have the problem, post to the mailing list. If you have a support contract, send email to
support@radiatorsoftware.com. Be sure to include at least the following information:

a. A detailed description of the problem.

b. Your Radar and Radiator configuration files (remove any secrets and passwords first).

c. An extract from your Radiator log file (with Trace level of 4) illustrating the problem, or at least what
is happening at the time of the problem.

d. Details of the computer type, operating system etc.

This information helps people to better understand your problem and help find a solution more quickly.

8.4. Announcements

There is a mailing list that just carries product announcements and upgrades. If you want to know about
upgrades available, but do not want all the technical volume from the normal mailing list, this may be the one
for you. You can check the available mailing lists and instructions how to join them from Radiator Mailing Lists
[https://radiatorsoftware.com/support/mailing-lists/].

8.5. Bug reports

We are interested in your feedback, both positive and negative, and bug reports. Please send them to
info@radiatorsoftware.com. Licensees are entitled to free upgrades, and we do fix bugs that are reported
to us, so if you report a bug, you can expect to get an upgrade with a fix one day. If you don't report it, it might
never get fixed.
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